[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 472: preg_replace_callback(): Requires argument 2, '(!empty($user->lang['$1'])) ? $user->lang['$1'] : ucwords(strtolower(str_replace('_', ' ', '$1')))', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/functions_content.php on line 660: preg_replace_callback(): Requires argument 2, 'Array', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/functions_content.php on line 660: preg_replace_callback(): Requires argument 2, 'Array', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/functions_content.php on line 660: preg_replace_callback(): Requires argument 2, 'Array', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/functions_content.php on line 660: preg_replace_callback(): Requires argument 2, 'Array', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/functions_content.php on line 660: preg_replace_callback(): Requires argument 2, 'Array', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/functions_content.php on line 660: preg_replace_callback(): Requires argument 2, 'Array', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/functions_content.php on line 660: preg_replace_callback(): Requires argument 2, 'Array', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/functions_content.php on line 660: preg_replace_callback(): Requires argument 2, 'Array', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/functions_content.php on line 660: preg_replace_callback(): Requires argument 2, 'Array', to be a valid callback
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3545: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2975)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3547: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2975)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3548: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2975)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3549: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2975)
Forum chinafonini.it • Leggi argomento - Guida all'installazione di programmi java

Guida all'installazione di programmi java

Discutiamo qui dei software compatibili con i chinafonini

Guida all'installazione di programmi java

Messaggiodi frk il 07/01/2011, 1:22

«Puoi guardare in faccia un ladro, ma non puoi guardare in faccia un bugiardo."
Paul Theroux - Hotel Honolulu
Avatar utente
frk
Site Admin
 
Messaggi: 27056
Iscritto il: 10/09/2008, 12:03
Chinafonini posseduti: Prince A960, JinPeng S6186, Smart M89, A7272+, Mpie MP108

Re: Guida all'installazione di programmi java

Messaggiodi fazius il 07/01/2011, 15:47

Per completezza diciamo una cosa per gli utenti che non sanno la differenza tra i file .jad e i file .jar

La differenza sta proprio nel tipo di informazioni contenute all'interno dei file:
per il .jad all'interno c'è il riferimeno su dove reperire il file .jar
per il .jar all'interno c'è il programma completo.

Per gli smanettoni il .jad si puo' aprire con il Blocco Notes di windows mentre il .jar si apre con WinRar perchè è un file compresso.
           Il sapere umano appartiene al mondo.           

Immagine     
Avatar utente
fazius
chinamaniaco
 
Messaggi: 773
Iscritto il: 12/01/2010, 15:34
Chinafonini posseduti: M002L

Re: Guida all'installazione di programmi java

Messaggiodi frk il 07/01/2011, 22:23

In realtà nel .jad non c'è sempre o solo l'indicazione su dove reperire il .jar, quanto piuttosto le impostazioni di installazione per il programma java, ed alcuni sistemi operativi di alcuni cellulari lo utilizzano per una corretta installazione.

In pratica, è l'equivalente del file .inf di alcuni programmi di Windows, e può contenere anche le indicazioni di licenza o di eventuale "scadenza" della validità per i software java commerciali.

Per fare un esempio pratico: se "infiliamo" un file .jar su un Nokia serie 40 lo possiamo eseguire direttamente, senza alcuna installazione. Basterà sfogliare la memoria fino al file jar e lanciarlo ogni volta. Ma se abbiamo bisogno di utilizzare un programma java complesso, che nagari necessita di autorizzazioni di lettura/scrittura o di utilizzo della connessione dati, potrebbe essere necessario installarlo mediante il file .jad.
«Puoi guardare in faccia un ladro, ma non puoi guardare in faccia un bugiardo."
Paul Theroux - Hotel Honolulu
Avatar utente
frk
Site Admin
 
Messaggi: 27056
Iscritto il: 10/09/2008, 12:03
Chinafonini posseduti: Prince A960, JinPeng S6186, Smart M89, A7272+, Mpie MP108

Re: Guida all'installazione di programmi java

Messaggiodi fazius il 09/01/2011, 11:58

Mi permetto di dissentire con il capo :fischio: , ma il file .jad non è necessario per le installazioni. Il tutto è contenuto nel file .jar.

Ecco in questo url è contenuta la differenza tra .jar e .jad e io con la mia esperienza di programmatore posso confermarlo:
link rimosso dall'amministratore
           Il sapere umano appartiene al mondo.           

Immagine     
Avatar utente
fazius
chinamaniaco
 
Messaggi: 773
Iscritto il: 12/01/2010, 15:34
Chinafonini posseduti: M002L

Re: Guida all'installazione di programmi java

Messaggiodi frk il 09/01/2011, 13:28

E io mi permetto di dissentire con te ;-)

Ti assicuro che su alcune marche di telefoni e alcuni sistemi operativi proprietari il file .jad è necessario per l'installazione. :sisi:

Inoltre , per poter utilizzare alcuni programmi java con tutte le autorizzazioni necessarie, può essere indispensabile installarle mediante il file .jad. Ti faccio un esempio pratico: su alcuni telefoni, se apri WeTravel direttamente dal file jar, questo viene visualizzato senza interfaccia grafica, senza sfondi, senza nemmeno le mappe sotto alle indicazioni GPS, risultando praticamente inutile. Bisognerebbe poi entrare nei settings e applicare a mano, uno ad uno, i singoli permessi di lettura dalle varie cartelle che contengono gli elementi dell'interfaccia e le mappe. Se invece esegui l'installazione dal file .jad, questa procedura indicherà correttamente al programma tutti i percorsi necessari al caricamento degli elementi grafici.

Inoltre, ho sperimentato da solo che con alcuni programmi java commerciali (trial o a pagamento) l'apertura del file .jar non andava a buon fine e un messaggio avvertiva di utilizzare il file .jad. Se la licenza contenuta nel file .jad era già scaduta, l'installazione non veniva eseguita.

E ancora, alcuni manager software, come il Nokia PC Suite, utilizzano il file .jad per eseguire l'installazione da PC, esattamente come il file .inf viene utilizzato da Windows, esempio che avevo già utilizzato.

...e ancora 2 (la vendetta :lol: ), in caso di applicazioni certificate, il file jad è indispensabile perchè contiene il certificato stesso, come si evince da queste istruzioni (fonte http://www.codeproject.com/):
"Your Java Midlet consists of two files: a JAR file and a JAD file. The JAD file is a descriptor file that specifies information about your JAR file. The JAD file is the file that has to be signed with the certificate, not the JAR file (this is why so many people go wrong!)."

Io rispetto la tua esperienza di programmatore ma, senza voler fare polemica, non vedo perchè quella pagina che hai linkato (tra l'altro vietata, perchè sito italiano che si occupa di telefonia mobile), scritta da chissà chi, dovrebbe essere più attendibile delle informazioni fornite da me. ;-)
«Puoi guardare in faccia un ladro, ma non puoi guardare in faccia un bugiardo."
Paul Theroux - Hotel Honolulu
Avatar utente
frk
Site Admin
 
Messaggi: 27056
Iscritto il: 10/09/2008, 12:03
Chinafonini posseduti: Prince A960, JinPeng S6186, Smart M89, A7272+, Mpie MP108

Re: Guida all'installazione di programmi java

Messaggiodi fazius il 09/01/2011, 17:37

Per quanto riguarda il link è stato il primo che ho trovato e mi sembrava solo di programmazione e siccome qui non si parla di programmazione,...

Per quanto invece rigarda la differenza tra .jad e .jar mi documenterò meglio :ciao:
           Il sapere umano appartiene al mondo.           

Immagine     
Avatar utente
fazius
chinamaniaco
 
Messaggi: 773
Iscritto il: 12/01/2010, 15:34
Chinafonini posseduti: M002L

Re: Guida all'installazione di programmi java

Messaggiodi frk il 09/01/2011, 20:35

Permettimi però di dirti che la polemica mi sembra comunque oziosa, perchè questo topic voleva essere una guida per principianti (altrimenti gli utenti avanzati non hanno bisogno di una guida per utilizzare dei programmini java sul cellulare). Nel primo post avevo solo detto di prendere il file .jar e non il .jad, tutto lì. Se sei d'accordo, estrapolerei la successiva discussione scorporandola dal topic.
«Puoi guardare in faccia un ladro, ma non puoi guardare in faccia un bugiardo."
Paul Theroux - Hotel Honolulu
Avatar utente
frk
Site Admin
 
Messaggi: 27056
Iscritto il: 10/09/2008, 12:03
Chinafonini posseduti: Prince A960, JinPeng S6186, Smart M89, A7272+, Mpie MP108

Re: Guida all'installazione di programmi java

Messaggiodi zonatar il 09/01/2011, 20:43

a me basta che nel mio prox w302d si possa installare jacksms java e sono contentissimo!
Avatar utente
zonatar
chinanovizio
 
Messaggi: 90
Iscritto il: 15/12/2010, 19:54

Re: Guida all'installazione di programmi java

Messaggiodi michele22373 il 15/01/2011, 9:48

carissimi,
grazie della magazione sul come installare il java,
perdonatemi però: mi date un link dove prendere il benedetto .jar da inserire nel sciphone i10 4w?
me lo hanno regalato e non ci capisco niente, sono sempre stato contrario a tali telefoni ma ora....forza maggiore.
Mi serve skype perchè vado all'estero.

cosa devo cercare nel web?
------
I programmi java per cellulari, ovvero le midlet java J2ME, sono piccoli software UNIVERSALI, utilizzabili su qualunque dispositivo portatile dotato di supporto Java MIDP. Per questo motivo NON BISOGNA CERCARE un programma java PER IL PROPRIO MODELLO DI CELLULARE.

Gli unici parametri che devono essere compatibili sono la risoluzione dello schermo (240x320, 240x400, 320x480 etc.) e la versione MIDP (1.0, 2.0, 2.1 etc.).

Il programma java che vogliamo installare deve essere sotto forma di file con estensione .jar. Alcuni programmi vengono distribuiti con un secondo file con estensione .jad che però, da solo, non è sufficiente per utilizzare il programma (mentre il file .jar può funzionare anche in assenza del file .jad).
-----
michele22373
chinapassante
 
Messaggi: 4
Iscritto il: 14/01/2011, 14:28
Chinafonini posseduti: sciphone i10 4w

Re: Guida all'installazione di programmi java

Messaggiodi frk il 15/01/2011, 9:57

A quanto si capisce dal sito skype, non esiste una versione java del programma: http://www.skype.com/intl/it/get-skype/ ... /download/

Come vedi c'è solo per telefoni Android, o Symbian o iPhone.
«Puoi guardare in faccia un ladro, ma non puoi guardare in faccia un bugiardo."
Paul Theroux - Hotel Honolulu
Avatar utente
frk
Site Admin
 
Messaggi: 27056
Iscritto il: 10/09/2008, 12:03
Chinafonini posseduti: Prince A960, JinPeng S6186, Smart M89, A7272+, Mpie MP108

Prossimo

Torna a Programmi, giochi, utilities java

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

cron